New Video Tutorials for One Engine

Updated on Sep 11, 2015 in OneEngine
167 on Aug 5, 2014

I have started making video tutorials on solving some of the particular issues I have come across while working with One Engine.

I am open to taking suggestions on future videos. If you are a beginner check them out! If you are a pro help me help everyone else! Shout out to kbengmy!

tutorials so far:

    • Contact form 7 email issue fixed

    • slider text removal / change

    • services clickable / linked

    • contact form and footer set up

http://www.joshuacasper.com/wordpress-tutorials/

  • Liked by
  • Bolaji Olajide
  • silentstephi
  • kilikoi
  • +7
4 on Aug 5, 2014

Thanks

on Aug 5, 2014

you’re welcome. let me know if there are any topics you would like me to cover in the series.

on Dec 8, 2014
you’re welcome. let me know if there are any topics you would like me to cover in the series.From joshuacasper

 

Need Help,
How to set Testimonials single  images on center in oneEngine Theme….

on Dec 17, 2014
 
on Feb 5, 2015

Hey Joshua… you doing a great job. While I have fixed most of my desktop website (openworldacademy.in) using your tutorials, my mobile site is still a mess with  lot of overlapping sections. Tried using wptouch pluggin but did not help. 
Would be great to see you cover that topic. 

Show more replies
  • Liked by
Cancel
0 on Aug 7, 2014

Really nice. I keep have problems with the Testimonials. In the demo the photo’s of the people that have something to say are popping out (so in front of the text etc.). When I upload a featured photo in a testimonial, they are at the back so they’re cut off if you know what I mean. I will search around this forum for a solution as well.

  • Liked by
Cancel
4 on Aug 7, 2014

New Tutorial: Adjusting the Layout of Portfolio Posts. Essentially, I go into the php file in order to change the size of the feature image so the content area is larger. 

http://www.joshuacasper.com/random-tutorial/one-engine-tutorial-adjust-portfolio-posts/

on Aug 7, 2014

Nice one as well! Do you know how to set up the site just as the demo section from ‘Our Clients’ till ‘Blog’? Especially the part with the photo’s popping out! Would be really awesome.

on Aug 7, 2014

How would you do this for a youtube video?

on Aug 7, 2014

You do it the same way. First, figure out the best size for the feature image in relation to your videos by following along with the tutorial.. The instead of a soundcloud player embed a youtube video.. for embeding responsive youtube videos i use Advanced Responsive Video Embedder”. 

on Jan 1, 2015

I used the Advanced Responsive Video Embedder, I get the play button but when clicked, it does nothing. I enabled lazy load and am also on a local server using MAMP

Show more replies
  • Liked by
Cancel
1 on Aug 7, 2014

Hello, i seem to be having a problem with my theme options in OneEngine, whenever i try to click any of the options (general, typography, footer for example) it gives me this message: http://prntscr.com/4aink4   Because of this message, i assume that there is noting in the files for it to pull on.  Should i just redownload?

If you know how to fix this i would be very grateful!

Thank You,

-Jack Kurtz

on Aug 8, 2014

yes. i have no idea what is going on. a fresh install might do the trick.

Show more replies
  • Liked by
Cancel
4 on Aug 8, 2014

Another New Video Tutorial:

Remove Title Lines | All or Individually

on Aug 13, 2014

Hi Joshua, your videos have been great! Can you do a tutorial on the quirks of the theme on mobile devices? For example, images/logo not resizing properly, how to resize the text when it seems too large, and parallax issues? Thanks!

on Aug 14, 2014

I will look into it. 😀

on Dec 29, 2014

Hey Josh, thanks a lot for your great tutorials. Have you been able to get the theme running on mobile devices? The site I built with it works on ’em, but the backgroundpictures I use with parallax are not getting scaled down. Therefore one can only see as many pixels from the left side onward as the device got display width…. I hope, I will not have to change the theme because of this…. Tested on Android 5 with chrome….

on Feb 4, 2015

Hi

same problem here, parallax images won’t scale on mobile devices… Did you guys found a solution? Thanks for sharing…

Great tutorials Joshua, helped me a lot to quickly setup the theme. Thanks a lot.

Show more replies
  • Liked by
Cancel
2 on Aug 14, 2014

New Tutorial: Main Menu Setup / Linking

http://www.joshuacasper.com/random-tutorial/one-engine-main-menu-setup/

on May 15, 2015

Hi,
The menu doesn’t seem to work if more than one word is used. So if my menu item is “About” that works well, but if it’s “About Us” the menu works. I do need multiple words for some of my menu items. Can you please explain how to achieve this?

Thanks in advance!

on May 15, 2015
Show more replies
  • Liked by
Cancel
0 on Aug 16, 2014

Man I love you!!

Thank you so much, your videos really helped me 🙂 Such a great job.

  • Liked by
Cancel
1 on Aug 18, 2014

Hi, I tried switching my theme over to OneEngine, but none of the pages showed up except the home page and the OneEngine contact form. My nav menu appeared, but it was improperly formatted and on two lines. Are there any tutorials about switching to OneEngine from another theme? My site is currently on Thesis. Thanks.

on Aug 19, 2014

hey there. i think that switching / importing from a different wordpress site might not work well because of the customization done to the shell of OneEngine.

Show more replies
  • Liked by
Cancel
5 on Aug 19, 2014

Hi Josh, thanks for your videos, they’re great! Can you help me with something? I love the simple One Engine one page layout, however, I want to add an Woo Commerce section to my site which I’ll need extra pages for. I’m not very clear about how this works with a One Page site, is it possible? When I try adding extra pages it seems to change my home page. What’s the best way of adding extra pages and then linking to them in the Home Page menu? Any help with this would be amazing! Thanks.

on Aug 19, 2014

I will look for a solution for this later today. I will keep this thread updated with any progress.

on Aug 19, 2014

TomF,

Making a MENU in another PAGE is easy. You can copy the code from here, http://getbootstrap.com/examples/navbar/# then change the name and link to suite your need.

The challenge is how to make the MENU link to the same page as in HOMEPAGE? This you have to edit the Container (open) PHP file.

Will give this in another post once I got the time.

Cheers.

on Aug 19, 2014

found a temporary workaround for this .. check the page and video :: 

http://www.joshuacasper.com/random-tutorial/one-engine-new-page-main-menu/

i would like to load the shell for the oneengine theme on each additional page.. like the menu and header.. @kbengmy maybe you might have some ideas

on Aug 22, 2014

Could also just add this line of code to the main.js …

 $('#main-menu-top a,ul.slicknav_nav li a').click(function(event){
if(this.hash != "") {
 event.stopPropagation();
 event.preventDefault();
 if($(this).hasClass('active'))
 return;

just make sure to add a closing bracket, IE: } , at the end, or else your site will not go past the loading screen.

I have been using this theme for the past few days as I design www.nikkitattoo.com and have even added a “test” link in my menu (for a limited time) to show everyone this does work as well. Next step, like kbengmy already said, is to get the “original” or “home” menu to basically “come along” or “transfer” over to the newly added menu item’s page. I will figure this out within the next 24 hours and let everyone know. Thanks for everyone else’s help on these forums as well.. it’s much appreciated. And if anyone sees anything on the site I’m designing that they notice I have customized – and wants to know how – just ask me.

on Aug 22, 2014

…not sure why my code is getting scrambled but the line of code is:

if(this.hash != "") {

Show more replies
  • Liked by
Cancel
5 on Aug 19, 2014

joshuacasper,

Nice!

Thanks for the sharing and videos, you are awesome!

on Aug 19, 2014

you are awesome!! I looked for a way to message you, but couldn’t find any methods. do you have an email or something?

on Aug 19, 2014

joshuacasper,

You can find it in my demo site (oneengine.eu5.org), or leave a message there.

Anyway, you can email me at kbengmy@hotmail.com

Thanks again for the videos, I know it is tedious to do all this. Good job!

Cheers.

on Dec 18, 2014

how to make load first slider image in oneengine theme and it would be appreciation to all ………

on Feb 17, 2015

Hi, thanks for all the videos and stuff as well. I might have just solved some more of you header problems. I don’t know where the most appropriate place is to comment, but I’ll drop this line on the YouTube video for creating external pages as well. I had serious issues in creating a custom template, but it’s just not doing the get_header()… And Boom, go to header.php and look for

 if( is_front_page() 
Change it to
if( is_front_page() || is_page()  
Voilà Of course there’s is_page_template and all sorts of things as well…

on Feb 17, 2015

This commenting system’s is really bad… 

Show more replies
  • Liked by
Cancel
2 on Aug 19, 2014

joshuacasper,

Watched your MENU LINK video and found out the URL setup section is not correct. I apologize for the misleading MENU link setup that I have posted earlier in OneEngine forum.

With the help/reminder from o edo (If you would like to contact o_edo I will check with him first before I reveal the email address here) and I have updated the mistake that I have made in this post http://forum.enginethemes.com/thread/correction-menu-item-underline-color/ .

Appreciate if you can update this on related section so others not making the same mistake I made before.

Thanks for you time and effort for creating a series of One Engine video tutorial.  

See u.

on Aug 19, 2014

thank you. i have updated my site and left a note on the videos.

on Aug 20, 2014

joshuacasper,

Really appreciate the update.

Show more replies
  • Liked by
Cancel
5 on Aug 21, 2014
on Aug 29, 2014

I noticed that you add custom themes to WordPress by going to the Themes page and selecting “Add Themes,” and I do not have that option on my themes page…  I have also not had success with the SampleData.xml import.  Do you have to have a special WordPress account for this feature such as Premium, Custom…?

on Aug 30, 2014

Sounds like you have a bad copy of wordpress. I suggest you remove all files from your FTP, then re-install wordpress from their website.

on Oct 24, 2014

Joshua,

For the video as featured image… does this not work if you use a video from your media library instead of a YouTube, Vimeo, etc?

I’ve been experimenting with the OneEngine theme and followed your instructions to put a video in the slider, but… it doesn’t seem to be working quite as yours does in your instructional video.

I initially tried using a video from my media library, but… it doesn’t autoplay and ends up with a play button in the very top left corner of the screen… partially off the screen in fact.

So, I tried the YouTube route and, it does autoplay, but ends with the big red YouTube play button (in your instructional video, you don’t see your example play to the end, so… is that unavoidable once it reaches the end of the video?).

Also… while they’re just off the bottom of the screen… the youtube controls are present throughout, which I don’t see in your example???

In an ideal world I’d have preferred to have used video from my library instead of use an external feed from YouTube, but essentially… just want it to display without any other controls and either end with the last frame and no play button, or to loop continuously. (OR… automatically scroll down to the main content when the video ends?)

Oh and… the button for scrolling down to the main body of the site that normally appears over the featured image… that no longer appears, so… does that mean the viewer has no option other than guess they have to scroll down after the video has finished?

You can see my test at http://www.outlawlive.co.uk/jftest 

Any advice would be greatly appreciated. 🙂

on Oct 29, 2014

you need to get into the settings of the feature video plugin. there are a number of options that will help you get what you want. 

as far as the youtube thing.. yes, it has to be vimeo, youtube, or dailymotion if my memory serves me correctly

on Oct 29, 2014

Thanks for the reply, Joshua.

It does offer within that featured video plugin the option of adding video from your media library… perhaps an update to the plugin since you made your video guide?

Anyway… it just doesn’t display right.

Doesn’t appear to want to auto play when using a video from the media library, and sticks the play button in a weird place.

I’ll try taking my query to the support forum for the plugin to see if anyone has an answer there.

Anyway… I wouldn’t have even known I could put a video in the slider (or a how to do a few other things!), without your video guides, so… very much appreciated.

If I get any help elsewhere and figure it out… I’ll post here for everyone else to see.

Thanks. 🙂

Show more replies
  • Liked by
Cancel
0 on Aug 31, 2014

Hi, I have an ET Button block underneath my pricing, and I want to link it to the bottom of my page where my contact form is set up. I have the contact form from Joshua Casper’s videos on YouTube, and I just want to know how I can link that button to the bottom of my homepage (contact form). Thanks.
http://www.dylangeewebdesign.com

  • Liked by
Cancel
1 on Sep 2, 2014

dylangeewebdesign,

Visit your website just a moment ago. Looks like you have resolve the problem?

Cheers.

on Jan 29, 2015

Hi kbengmy,

Can you help me on how to link ET Button to different page?
Thanks

Show more replies
  • Liked by
Cancel
0 on Sep 5, 2014

in the blog section “View All Blog” where is control for “View All Blog” in the dashboard, i would not find it

  • Liked by
Cancel
1 on Sep 5, 2014

Hi Joshua,
Awesome site, and your tutorials helped me start my website. I am having trouble with the blog section of my website. I placed a thread here on the forum but I haven’t got any answer yet. I’m hoping you could give me some advice if you can. So the problem is that when you click “read more” for a post it takes you to the main blog page and the post are still cut off. Here is my website eko3dstudio.com 
thanks so much for the help

on Sep 6, 2014

Sorry, I figured it out after comparing it to the demo site. Thank you

Show more replies
  • Liked by
Cancel
0 on Sep 11, 2014

Good afternoon, Does anyone know how to theme OneEngine run on safari?

  • Liked by
Cancel
0 on Sep 16, 2014

I have created my site and provided content in the ET about section in the layout. But in the site, when I scroll down, the content keeps showing about the parallax section.

Can  anyone help me here?

  • Liked by
Cancel
1 on Sep 17, 2014

Varun,

Can you post a screenshot of your ET About setting?

Or best if you can share your URL as well.

Cheers.

on Sep 17, 2014

Hello Kbengmy,

Please visit the site http://clarionenterprise.in/
a
nd help me on my query. when i scroll down the about content gets smudged in the top header, you can notice that…..
please provide help….
thanks in advance…

varun

Show more replies
  • Liked by
Cancel
9 on Sep 17, 2014

Varun,

Add following to Custom CSS,
#header.stuck-sticky {
 z-index: 9999;
}

Actually quite hard to notice because your ET About text is white color and your menu bar background is white as well.
Cheers.

on Sep 17, 2014

Fantastic, 
It helped and solved…..
did you like the site? i have applied montserrat font for the blog etc…but it does look very smudgy and not clean and sharp…can you please let me know how to make it better?

on Sep 17, 2014

Not attempting to be rude – just honest. The design is horrible. There is no color scheme – every block is a different color which is visually unattractive. Plus, you aren’t even using the best part of the theme – the parallax background option with images / designs. For a small fee I can complete your website for you to look 100% professional. Contact me admin@jus3d.com or tone@ic3d.net

on Sep 18, 2014

Hello JusDigital, 
Can you show me your work on this theme? some examples!!!

on Sep 29, 2014

Sure, www.nikkitattoo.com .. I put that together a few weeks back. 😉

on Sep 29, 2014

http://www.nikkitattoo.com

on Oct 9, 2014

JusDigital  – Awesome work. Whoa!

on Oct 9, 2014

How do you get the slider to automatically “slide”?

on Oct 9, 2014
How do you get the slider to automatically “slide”?From elboyyoloco

http://www.joshuacasper.com/random-tutorial/slider-auto-rotate-set-time/

on Oct 10, 2014

Thank ya kindly joshuacasper!  Appreciate all the video tutorials.

Show more replies
  • Liked by
Cancel
Loading more replies
Posting & Replying function will be deactivated from 3pm GMT+7 12th Sep.
Read More